Honda CR-V Owners Club Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
My engine light has been coming on for a few days, but it will also go out, only to come back on. It has been cold, around 2 degrees, and even though it is in a garage, it seems to be starting just a tad rough. By this I mean it may grind for up to 2 seconds, but never has done this in the past. I also notice that there may be a slight drop in power when I speed up, and possibly sounds a little too loud, but I may just be a little jumpy and noticing things I didn't before. I had a guy at Autozone read the code, that is where i get the P0341. From some reading I am doing it sounds like this could be the start of a serious major issue.

The car has 188,000 miles on it, so I do not intend to spend a whole lot on repairs. I am not really a mechanic, so have some fears about taking this in for a look for fear of it it needing to be torn apart just to diagnose it. Looking for some guidance on what could be wrong, anything simple I could do, or just experience on what the next steps should be.

Thanks

Tony
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
One more question. I have been all over the web and am having a hard time finding this part. Is it the one listed as VALVE ASSY., VTC OIL CONTROL, no. 10 on the attached drawing?

Thanks

VTC.jpg
 

·
Everything in Moderation
Joined
·
7,736 Posts
Yes, number 7 is what you need (if you are gambling that the valve is the culprit).
 

·
Registered
Joined
·
39 Posts
Discussion Starter #7
Thanks, I am not sure what to do. The light was on when I started the car today. Went to a store and when I next drove it, the light was out. I was under the impression that once the check engine light goes on, it has to be reset. Mine seems to be going on & off. I checked Honda and they want something like 4135 for the part. He has it in stock & I will need to check it out because when I asked about the O ring he said their are 3 of them and they fit in a housing. I also have to look at my car to see that this picture does agree with mine.
 

·
Everything in Moderation
Joined
·
7,736 Posts
Sometimes CELs will go out by themselves, depends on the malfunction.

The troubleshooting link I sent you previously, had a pic of the valve and it's attachment bolt, on the RH side of the engine (below the power steering pump).

The parts list seems to indicate that the o rings are included (#8). The place you got the diagram from will have a parts list, the one on Bernardiparts.com says one o ring.

Bernardi wants ~$97 USD + shipping for that part,list price is $138.

PartNo: 15830-PNC-003

Don't forget to coat the new o ring with ATF or rubber hose grease, so that it will slip right in.

 
1 - 8 of 8 Posts
Top