Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi, so i just disconnected a siren so i could replace the interior light fuse also cleaned up the connections on the rear light so all settings worked.
I then went to see if somehow the repaired connection had fixed my no power to radio problem. So whilst testing with a meter i disconnected the hazard switch and ensured my meter was working (it was) so after finding i still didnt have power to the stereo i put it back but found that the indicators were no longer working nor the hazard switch. So i checked the power with the meter and no power at the switch now, after checking both fuses and finding them intact im unsure what has happened.
Any advice appreciated

Rich
 

·
Registered
2003 Honda CR-V EX a/t
Joined
·
1 Posts
Hey there, sorry to bump an old post! I have an 03 CR-V, i had to drive my vehicle while doing a stereo and having the dash ripped apart once..while driving, I noticed I had lost my signals. I thought to myself, the only thing different between then and now was the front bezel around the stereo was removed(also containing the hazard switch)...I slapped the bezel up, plugged the harness into the hazard switch and my blinkers were once again operational. Not sure if this helps but..the two things I would check are that the switch be connected to the harness and if so, check for a bad hazard switch.

Brandon
 

·
Super Moderator - How may I help?
Joined
·
3,671 Posts
Welcome to the forum, BHeryford! Nice way to begin here, offering up some help!
 
1 - 5 of 5 Posts
Top