Honda CR-V Owners Club Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi there, I have a Honda CRV EX 5AT 2006 model, with approx 50K miles on it.

I am noticing that the Check Engine, VSA and the "!" indicator would show up repeatedly even after the Honda Dealer in Burlington, MA would fix the issue. So far on two occasions when the above indicators came up, they did the following: (1) replaced a Selenium part on the first occasion and (2) later they told me the firmware needed to be updated, which they did.

None of these appear to have solved the Check Engine, VSA and "!" indicator showing up. They just show up at random and when all three show up, the car just starts shaking.

I've noticed that all three show up when I am in stop-and-go traffic.

Usually when I restart the car, only the Check Engine indicator shows up.

Any thoughts on what could be the cause?

Additional context: I had noticed last year that the temperature indicator on my dashboard would go toward hot. The Honda Dealer in Burlington, MA told me that they suspected a head gasket problem, with the coolant leaking into the engine and getting burnt off. After a couple of times they replaced the coolant, they repaired the head gasket for the engine, which was a pretty expensive repair.

Have you folks seen the above Check Engine light behavior with your Honda CRVs?

Also can anyone recommend an independent Honda repair shop OR good service experiences with Honda dealerships in the metro west area of Boston?

Thanks for your help!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
I went to AutoZone and got the diagnostic code:

P2646

Definition: VTEC oil pressure low voltage
Probable cause:
- Check engine oil level and pressure
- Open or short circuit condition
- Failed VTEC pressure switch

I am due for an oil change 5/15 or 52,000 miles and I am currently at 50,000 miles.

Any thoughts based on the above?

Thanks!
 

·
Registered
Joined
·
3,386 Posts
The VSA light would normally come on if the check engine light is on. As this is saying that the traction control is off to prevent damage on the system. Does the vehicle drive differently if the check light is on? What is the oil level on the engine? It could also be a clogged VTEC strainer.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
When all 3 lights come on, the vehicle does shake and the engine RPM revs (sorry if I am not able to articulate this clearly). When this happens I pull over. After I restart the engine, only the check engine light comes on. The car then drives normally. However, the VSA and the ! indicators will also come along some times. Not sure about the oil level in the engine. I need to take the car for an oil change by 5/15.

The dealer had earlier replaced the Solenium and then last time, they told me that a software update was necessary.
 

·
Registered
Joined
·
1 Posts
Hey I'm having the exact same issue with my 2006 Honda CRV. Can I ask you what the outcome was with yours. I appreciate your help. I've just sunk about $1500 into the front end and new brakes and rotors and new tires so I really don't want this to be the end of this car. Hoping you can help.
Thanks :)
 

·
Registered
Joined
·
3,386 Posts
Hey I'm having the exact same issue with my 2006 Honda CRV. Can I ask you what the outcome was with yours. I appreciate your help. I've just sunk about $1500 into the front end and new brakes and rotors and new tires so I really don't want this to be the end of this car. Hoping you can help.
Thanks :)
We'll get you help to get this resolved. Is the vehicle running normally? Usually the triangle & other warning lights i.e. VSA comes on even they don't have problem to prevent them from working & damaging other systems. Was anything done before this happened? Have you have the vehicle scanned for codes?
 

·
Registered
Joined
·
1 Posts
Hey I'm having the exact same issue with my 2006 Honda CRV. Can I ask you what the outcome was with yours. I appreciate your help. I've just sunk about $1500 into the front end and new brakes and rotors and new tires so I really don't want this to be the end of this car. Hoping you can help.
Thanks :)
I am having the exact same issue with my 2006 CRv. The car has felt like it was lurching a bit when I got to accelerate and I went to Autozone and received the VTEC oil pressure code. What was the fix you ultimately required?
 

·
Not-a-Mechanic
2011 CR-V 4WD EX
Joined
·
419 Posts
Well the OP was a long time ago, but Sarah was here just 2 months ago. Maybe try to contact her.
And please report back!
 
1 - 9 of 9 Posts
Top