Honda CR-V Owners Club Forums banner
Status
Not open for further replies.
1 - 7 of 7 Posts

· Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
no CEL, no codes, starts and runs fine. when cold, off idle it's "jumpy" as in a surge kinda of with rpm, around the 1500ish-3000ish range. seems to get a little better as it warms up and gets temperature. in my opinion it's acting as if the TPS is messed up, gets to a certain rpm point and starts doing it. what throws me off is NO CEL/MIL are on, and no codes. checked wiht a matco pro scan plus scanner, NOT the honda HDS. my service manual says to check the APP (accelerator pedal position) sensor, it should be less than 2% to be considered ok, my matco scanner is calling it throttle position, so not sure it's even that same sensor my scanner is reading. anyway KOEO the TPS is at 18% closed, KOEO *** is at 79%. seems to me my TPS is garbage, but wanted to check with others and see ur opinions....
 

· Registered
Joined
·
67 Posts
Discussion Starter · #4 ·
dirty throttle body makes sense for it to compensate and change the numbers, but it would start sensing all that once the engine is running, no? those percentages I have are all with the engine off, KOEO. so, from tigris post, mines almost double what it should be-no good. can't just the sensor be changed or do you need to get the whole sensor/spring assembly?
 

· Registered
Joined
·
67 Posts
Discussion Starter · #5 ·
what's the "throttle position" measuring, anyone know? is it the "APP" sensor the throttle cable connects to on the firewall, or is it the actual sensor/motor down on the throttle body?
 

· Registered
Joined
·
67 Posts
Discussion Starter · #8 ·
well based on my 18% closed and 79% open, sounds like cleaning the throttle body is the first thing to do, and then the idle relearn procedure after. question, when I do this, do these engines have an IAC? looked online and some engines/vehicles had it under the throttle body, looked in my service manual and didn't fine one. I wanna take this off too and clean it while i'm in there doing the throttle body.
car is a 2006 2.4 AWD auto


thanks again
 

· Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
On the off chance that I'm stating the obvious:

++++++++

Regards your other question: Honda only sells the entire throttle body containing the TPS sensor for the Gen2, and they rivet it in for good measure. :beb: Aftermarket DOES sell just the TPS.
noticed these sensors are slotted for adjustment, any clue how an aftermarket one would go on in term of adjusting properly?
 

· Registered
Joined
·
67 Posts
Discussion Starter · #11 ·
think I understand, so instead of a valve that's regulating/moving air flow at idle, that's whole part is eliminated, and the whole process is done through the actual throttle body butterfly? you're corret too, mines an '06 and the throttle cable goes to the TPS/APP (wwhatever it's called) on the firewall, and it's all electronic, no mechanical attachments or linkages down to the throttle body on engine.

basically, my '06 doesn't have an IAC valve...
 

· Registered
Joined
·
67 Posts
Discussion Starter · #13 ·
nope it does not.

I'm not sure on that specific version (drive by wire) but previous the whole matter of the rivets and so on is nothing more than a mild annoyance if you have a dremel.

This applies I know for sure to 2002-2004:

Their not rivets. They are screws that the heads snap off when tightened to torque.

Replacement TPS come with new screws. You use a dremel or similar (a small and sharp chisel can be used with caution though) to put a notch in the head of the "rivet" and use a flat blade screw driver to remove. No big deal.

As for install since you have access to a scan tool it's really simple (though to be honest how you have an expensive scan tool but no knowledge of how to do a task like this is a bit confusing).

Put the new TPS on and do not not tighten down fully. Snug but enough you can still turn it. Set the throttle body back in and plug ALL connectors and such back in. then turn the key on (never start engine at this point). Check scan tool to see what it says throttle position is. If it's more than around 8-10% then need to shut key off, adjust sensor. Once it's there, tighten up screws and fully reassemble. Good to go. There is a specific output voltage from the TPS which setting it at that puts the reading between 8 and 10% Mine was between 9 and 10.

Sent from my SM-G950U using Tapatalk
what about how someone else in this forum prior said that it keeps a "stored value"? Meaning mine at 18% KOEO is a stored value?! also you mentioned setting the throttle body back in, I don't have to remove that for changing the TPS do I? as far as TPS swap goes, it's all done right there on the firewall it looks like. Are there any "relearns" that have to be done after the TPS swap, or do the idle learn control over again?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top