Honda CR-V Owners Club Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone , I hope all you guys fine and in good health .
I need someone to help me with my 2007 CRV . I just replaced my front wheel bearings and Axles on both sides , the ABS VSA light came on . Checked with my scanner and it showed left speed sensor .Replaced it with after market from Auto Zone for a little bit more than $100 and still the same . What do you think guys ? The OEM one will fixed the problem .
Thank you
 

·
Registered
2007 CRV AWD
Joined
·
1,512 Posts
Hello everyone , I hope all you guys fine and in good health .
I need someone to help me with my 2007 CRV . I just replaced my front wheel bearings and Axles on both sides , the ABS VSA light came on . Checked with my scanner and it showed left speed sensor .Replaced it with after market from Auto Zone for a little bit more than $100 and still the same . What do you think guys ? The OEM one will fixed the problem .
Thank you
On the 2007 CRV, there is USA made and Japan made vehicles.
Did you use the correct one?
I recently changed my right front wheel bearing with parts and tools off Amazon
It was one of the most difficult things I have done on the CRV.
Anyway, the ABS or wheel speed sensor broke.
Replaced it with a cheap Amazon one but made sure it is for Japan made (my vehicle).
There is also an issue of the wheel bearing going in the correct direction.
Only one side has the magnetic coding for the ABS sensor to read the speed
If that went in the wrong way then you will need a new wheel bearing again.
Good luck.

Note: First three of the Vin tells you if USA or Japan
5J6 is USA , JHL is Japan
Hope the wheel bearing is in correct??
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
On the 2007 CRV, there is USA made and Japan made vehicles.
Did you use the correct one?
I recently changed my right front wheel bearing with parts and tools off Amazon
It was one of the most difficult things I have done on the CRV.
Anyway, the ABS or wheel speed sensor broke.
Replaced it with a cheap Amazon one but made sure it is for Japan made (my vehicle).
There is also an issue of the wheel bearing going in the correct direction.
Only one side has the magnetic coding for the ABS sensor to read the speed
If that went in the wrong way then you will need a new wheel bearing again.
Good luck.

Note: First three of the Vin tells you if USA or Japan
5J6 is USA , JHL is Japan
Hope the wheel bearing is in correct??
Thank you for your advice, I really appreciate it.
 
1 - 4 of 4 Posts
Top