Honda CR-V Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
As the title says I have the ABS and VSA light come on after a suspension swap. In all honesty I am not 100% certain the lights came on after the suspension swap but that's when I noticed it. Its my mom's car. I checked all the sensors to make sure they are plugged in which they were.
Before I go out and buy 4 new abs sensors is there any simple DIY ways to better diagnose this problem? I connected my OBDCOM to check codes, but because there isn't a CEL no codes showed up.

Your help and advice would be appreciated.
 

·
Registered
Joined
·
172 Posts
What does a suspension swap mean?

Here are some things that come to the top of my mind

the half shafts you got dont have the ABS compatibility

The ABS sensors are damaged(all it takes is one to be damaged)

An ABS wire was broken

THe ABS sensor is not plugged in or the plug is damaged

a fuse is blown

Try checking for continuity with a test light or voltmeter with the existing ABS sensors before you buy new ones
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
What does a suspension swap mean?

Here are some things that come to the top of my mind

the half shafts you got dont have the ABS compatibility

The ABS sensors are damaged(all it takes is one to be damaged)

An ABS wire was broken

THe ABS sensor is not plugged in or the plug is damaged

a fuse is blown

Try checking for continuity with a test light or voltmeter with the existing ABS sensors before you buy new ones
Suspension swap means i replaced the shocks with new ones. Nothing fancy.
 

·
Registered
Joined
·
3,170 Posts
Double check the ABS sensor connectors if they are all tight. If so, you can try to do a hard reset before buying new sensor(s). Let us know.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I went ahead and changed all four sensors. That solved the problem. Cost $100 for parts only. I did the labor which was very easy.

Now I need to figure out why the tire pressure light is on...
 

·
Registered
Joined
·
3,170 Posts
Thanks for posting back the fix! For the TPMS light being on, check the basics first. I am not sure if the spare also has a sensor on it. I would start on that 1st see what the pressure is, then check all 4 tyres. Let me know.
 
1 - 7 of 7 Posts
Top