Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of December's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
The Honda Navigation App couldn't reach the server the other day so I pulled out my old GPS. As I neared the destination I received a low power warning. I looked down and saw the power connector plugged into the Accessory Power Socket had no LED on. I turned it back and forth but it never came on. I moved it to the socket in the console and it worked fine. So, looks like I need the Accessory Power Socket replaced. I know Honda is going to charge me a lot to do it and figure it cannot be that hard. Wondering if anyone has done this and has any tips or gotchas before I attempt it.

Thanks
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
Well, I checked the fuse and it is fine. I tried a couple of different adapters and found the same issue. They may or may not work. If I turn the adapter around I see it's power indicator go on and off. Looks like there are spots where the connection is no good, so it needs replacing.

Again, wondering if anyone has done this.

Thanks
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #6 ·
Well, This wasn't the easiest thing in the world to get out but it finally did. now my question is, do I replace the whole thing or does the metal somehow come out of the plastic and maybe be able to get a generic replacement at an auto supply store?
139580
 
1 - 8 of 8 Posts
Top