Honda CR-V Owners Club Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi, I am new to this forum. I just purchased a 2016 Touring and so far I am very satisfied with it except the radio. There are several local radio stations that all of my other vehicles pick up well but my Honda barely picks them up. The stations are statically and just sound terrible. I have not taken it to the dealer yet, doing a little research first. Is anyone else having or had this issue? Thanks.
 

·
Registered
Joined
·
3,154 Posts
1st of all welcome to the forum. Have you checked the basics? How about AM? Does the it receive good signals? Check the connector to the antenna that connects to the back of the unit. If you need a diagram I can post 1. Let me know.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thank you for your response. I have not checked the AM stations yet. Some of the FM stations are fine and some sound like 1970s portable transistor radio. I have a 1965 Mustang that picks up the local stations better. Send me the diagram and I will take a look at the antenna connection and see if it loose.
Thanks again,
Kascus.
 

·
Registered
Joined
·
381 Posts
Welcome!

I have a 2015 Touring (same car), and am picking up 31 channels on the FM dial. (plus digital sub channels that im not counting) They are all crystal clear, and free of static.

It depends on your market and distance from the antennas, but it works as well or better than any radio I have had in the past.

I think it may be possible that you have a loose or damaged antenna/wire, and that the dealer should take a look at it while under warrantee.

While the FM reception has been great, the XMRadio was not as great and frequently cut out while driving under trees, in garage, etc. (which may very well be normal) We recently let the trial subscriptions for that lapse, for both of our vehicles. I don't see the value of it in a market with so many radio stations.

Mike
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
I may have found the problem. There is no antenna at all. I guess the dealer forgot to put it on after shipment. I thought the shark fin served as the antena but I noticed it is missing a mast that should screw in to it.
 

Attachments

·
Registered
Joined
·
381 Posts
Wow! Well that would do it :)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
I went by the dealer today and they gave me a new antena mast. I have no idea what they did with the original. I noticed another 2016 CRV on the lot with one missing. I did go back and look at the advertising photo of the vehicle and it was missing then also. I guess Dealer prep is just an expensive car wash.
 

Attachments

1 - 11 of 11 Posts
Top