Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
When we bought the CR-V in February 2017 the caller ID worked great getting the caller's name if they were in the phonebook or number displayed if not. At some point it stopped working, now only getting an unknown caller message when calls come in whether the number is in the phonebook or not. I've changed the way the number is listed in the phonebook a few times to different versions of the number **** +1 704-XXX-XXXX and (704)XXX-XXXX **** each time deleting the phone from the radio and repairing to get the new phonebook but the caller ID on the phone always shows as +1 704-XXX-XXXX. It will never show (704)XXX-XXXX. I've read on other forums that the Honda radio looks for that format. The tech at the dealer had a Galaxy S7 that worked fine but I don't know which cell phone carrier he had. Also my daughters iPhone 6s does the same thing... unknown caller.

Am I the only one with this problem? Any ideas on a fix for it?

2017 LX
Samsung Galaxy S6 G920A running latest updates from AT&T (Android 7.0)
 

·
Registered
Joined
·
2 Posts
I have a similar problem. Bought used 2016 certified CRV April 2019, paired with Galaxy S5/Active worked fine. Paired with a Galaxy S7 (12/26/2019), worked fine for a week. On 1/2/2020 the entire infotainment system blacked out, came back on, blacked out again and came back on. The unit was some how totally disconnected from power during these 2 blackouts. After that, Incoming Calls only show the number not the Name (even if they are in the phone book). Dealing with the Service Department now as they said they fixed the issue but isn't. Have Honda Case Manager assigned. Two days ago, made a call via Hands Free Link, the Outgoing Name did not show up, only the number as the Incoming Calls are doing. Made another call to the same number from my phone and the Name shows. Today, while driving (and I videoed) the portion of the Call History screen with the numbers AND the Speed Dial screens had nothing on them totally black. When I stopped for a stop sign or a stoplight the information repopulated. As soon as I started driving it went black again. Once I switched between the screens and it populated and stayed until I turned the car off. When I started the car again, the data again disappeared and reappeared when stopped. Will be updating the Case Manager. I have AT&T.
 
1 - 2 of 2 Posts
Top