Honda CR-V Owners Club Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi,

I have an Honda CRV 2010 Diesel 2.2 Idtec.

Last week I was joining the motor way, put my foot down, and the engine went into limp mode and engine light on. I plugged in an OBDII computer and got code P0087, which says 'Fuel Rail/System Pressure - Too Low'. I was told maybe fuel filter would be blocked, so gave it a full service, and turned light off.

A week later, the same again. Going up slip road to join motorway and engine light came on with same code. The fuel fuel was on 2 bars, don't know if it has anything to do with fuel getting low. Any suggestions would be much appreciated.
 

·
Registered
Joined
·
575 Posts
I had mine refurbed. Wasn't that bad for 150K miles.

But let's not get ahead of ourselves. Go to a diesel garage and have them do a leak test. Might be something as simple as a leaky injector.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Okay, thanks for advice.

I'm on 67k atm. Most people on previous threads said a filter clean usually cures it. But no avail.

Found a refurbed pump cheap, what would a garage usually cost to change, just preparing for the worst case.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Just started after working night shift, the engine light has stayed off, but the engine is making a rattling noise it wasnt before, sound a bit like a tractor. Not sure if it is making the sound as it is cold, 4C. Can't here in when you pick up speed but can hear when idling and pulling away.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
Anyone else had any similar problems.

When I serviced it I used 5W 30 oil as stated on EuroCarParts, reading online 0W 30 is more suitable. Also read this can make the tapping noise, can this be true.

Thanks
 

·
Not-a-Mechanic
Joined
·
393 Posts
16471/P0087/000135 - Fuel Rail/System Pressure: Too Low
Possible Symptoms

  • Power Loss
Possible Causes

  • Fuel Pressure too Low
  • Mechanical Deficiency of Hardware (worn or missing parts)
Possible Solutions

  • Check Measuring Values for Fuel Pressure
    • Check for bent/squeezed Fuel Lines
    • Check Low Fuel Pressure System for Leaks
    • Check Fuel Filter & Filter in Fuel Pump
    • Check the Fuel Quantity supplied by the Fuel Pump
    • Check for fuel pressure loss from leaking fuel injector
  • Visual Inspection of Hardware (Camshaft, Cam Follower, ect)
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
Thank you. Shall work through the list.

When the light comes back on I shall take it to garage. So far its just a tapping rattling sound, when idling or pulling away. No lack of power, trouble starting or no issues with idling.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11
Can't find no bent or squeezed hoses, no obvious leaks, have also check injectors but no leaks. Fuel filter has been replaced, not the one in the fuel pump as this is a bit to technical for me lol.

If I take this to garage will they be able to check pressure loss and fuel quantity from plugging OBD2 in if the light comes back on.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #12
If I take this to garage will they be able to check pressure loss and fuel quantity from plugging OBD2 in, or shall I have to wait for the light to come back on first.

Thanks
 

·
Registered
Joined
·
575 Posts
They can check all the parameters from the OBD2 but only in theory. If the pump is worn then you only know how much it is instructed to pump (by the ECU) but if it leaks back then you don't, it can only be measured externally. That's what the on-board diagnostics system is doing - the calculated pressure is not met, so the error message is thrown. If the injectors leak then they need to be tested in a bench. You can do the leak test at home too if equipped but there may be more than one issue and it's just not worthwhile to do at home.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #14
Been at the garage today, had injectors checked but all okay.

After closer examination they realised the EGR pipe has split...

They have ordered a new one and shall fit tomorrow £430 later ?
Code:
 

·
Registered
Joined
·
17 Posts
Discussion Starter #15
So....

Turns out this was clearly a different problem.

Driving on the A14 after having the work done we broke down, accelerator stopped working and code P0301 came up, which is to do with engine misfire on cylinder 1.

The mechanic was convinced it was the injector when we towed it to him, so new injector bought and fitted and it is still no better ?.

Any suggestions, it runs but lots of white smoke, smell unburnt fuel.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #18
I know. I know. Extortionate. Should have bought used of ebay but needed the car back and thought it would fix the problem. The part was 240 with gaskets from Honda.
 

·
Registered
Joined
·
8 Posts
I have an issue with fuel rail pressure. Current diagnosis is the pressure sensor on the end of the rail has failed. Honda, in their helpful manner do not supply the sensors, but will sell the whole rail assembly - £1300. Part 1 on link below.


Doing a bit of research online, I think I need Sensor, fuel pressure BOSCH 0 281 002 534 High Pressure Side buy cheap online

The amusing part was a main Honda Dealer took 2 days to confirm what the AA man sussed in 30 mins! I even took his report, bastards better not try and bill 16 hrs labour.

Wanted to know if anyone had the same experience?

I will post outcome.
 
1 - 19 of 19 Posts
Top