Honda CR-V Owners Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Started car, ran great and when I got a few miles down the road and stopped at a light the car started running rough, has trouble picking up speed and is very sluggish, like it has no power. Car is hard to pick up and go. Amber engine light on the left dash is blinking on and off. Timing belt has been replaced. Any ideas or suggestions before I have to spend a bundle of $'s i don't have.
 

·
Registered
Joined
·
71 Posts
do not drive it! Have it towed. that is the check engine lite, when it blinks it means something is seriously out of range and it will cause damage to the engine if you continue to drive it. If you can get it to a place where they can check the code and see what it wrong that will tell you more about what it might need. It could just be a sensor or a loose connection that you can replace yourself, or it might mean something more complicated.

One thing is for sure, if you drive it while it is malfunctioning you will likely damage the catalytic converter or some other costly part. Usually this means it is running way too rich, and a few things can cause this, typically a bad sensor. or it may have some connector come loose from when it was serviced, and it is now in a "run rich/limp home" mode, but it could cause costly damage to the engine or cat if you continue to drive it.

You might inspect all of the connectors on the fuel injection system, sensors, hoses, etc and see if any of them are loose or need to be reconnected.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Petros98
Thanks for your quick response. I did have it towed to the dealership this morning and will update when I hear back. Many thanks again for a quick answer.
 
1 - 3 of 3 Posts
Top