Honda CR-V Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Has anyone installed this into their CRV? I'm trying to do it now but the wiring diagram they have does not look correct.

I am connecting it to the Sony XNV-660BT via wiring harness from Sonic Electronix.

I have done the following:

* Wiring it to the main (OEM) HU harness and not the OEM steering wheel control harness
* ASWC red-wire to harness red-wire (ignition switch)
* ASWC black-wire to harness black-wire (ground)
* HU Harness (brown wire) to harness black-wire (ground)
* ASWD gray/red (4th wire) to Pink HU harness

I'm not sure if the Pink wire is correct due to the incorrect wiring diagram. I found it via google.

The ASWC flashes and never goes solid so it's not programming itself. It does seem to recognize the HU as a Sony and I've got to confirm it recognizes the ASWC 4th wire as being connected.

I'm pretty much going to try the other wires on the harness but suggestions are most welcome!

I need the steering wheel controls since the Sony HU does not have physical keys for forward and back (like the x920bt) .. reviews of XNV-660BT to come!
 

·
Registered
Joined
·
295 Posts
Has anyone installed this into their CRV? I'm trying to do it now but the wiring diagram they have does not look correct.

I am connecting it to the Sony XNV-660BT via wiring harness from Sonic Electronix.

I have done the following:

* Wiring it to the main (OEM) HU harness and not the OEM steering wheel control harness
* ASWC red-wire to harness red-wire (ignition switch)
* ASWC black-wire to harness black-wire (ground)
* HU Harness (brown wire) to harness black-wire (ground)
* ASWD gray/red (4th wire) to Pink HU harness

I'm not sure if the Pink wire is correct due to the incorrect wiring diagram. I found it via google.

The ASWC flashes and never goes solid so it's not programming itself. It does seem to recognize the HU as a Sony and I've got to confirm it recognizes the ASWC 4th wire as being connected.

I'm pretty much going to try the other wires on the harness but suggestions are most welcome!

I need the steering wheel controls since the Sony HU does not have physical keys for forward and back (like the x920bt) .. reviews of XNV-660BT to come!
Gray/Red is the Pin 5 of the ASWC not 4, unless you made a typo. If the ASWC is in fact recognizing the HU, the problem must be with the SWC. If you know how to measure resistance, you should read 10K ohm between Pink and brown with the ASWC disconnect and between 100 and 6k ohm depending which mode button you are pressing. Otherwise your wiring looks OK.
Axxess has a C.S. 1-800-221-0932, they might be able to help you
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
thanks for your response. I'll check the wiring to confirm and unfortunately I do not have the equipment to measure the resistance on the wires.

have you done this installation before though? I really need to confirm the right harness to tap into ....
 

·
Registered
Joined
·
295 Posts
thanks for your response. I'll check the wiring to confirm and unfortunately I do not have the equipment to measure the resistance on the wires.

have you done this installation before though? I really need to confirm the right harness to tap into ....
Done it on my 2010 LX. Had to buy/install audio control on steering and modify harness at cable reel/clock spring to get access to SWC wire. Looking at the service manual, definitely, Pink (B7) and brown (B6) off the 20 pin B connector of your OEM radio are the right wires for the SWC and Pin 5 gray/red off the ASWC.
Pink B7 connects to gray/red (pin 5 ASWC) and brown B6 connects to black (Pin 6 ASWC) and to ground.
 
1 - 5 of 5 Posts
Top