Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My car has been increasingly getting worse over a period of 2 years with this problem. When driving the car acts sluggish when trying to accelerate slowly. It also happens when i keep a certain speed and then release the throttle a split second, and when i accelerate back. It feels like the car loosees power for just a half second before it starts reacting to my foot on the pedal. So that basically means that whenever i try accelerate, first the car "loose power" for a split second and the car slows down to the degree that everyone in the car thinks u stopped pushing the pedal, before the car starts to accelerate at all.

After using a diagnostic tool on the car, i found that one of the codes were for the EGR valve, and some other ones that were unspecific. The entire EGR-valve was cleaned out together with connecting exhaust pipes. This was probably 40% full of black stuff, sadly it didn't resolve the issue. I have a new dynamo as well, as one of the other codes communicated some voltage problem. Both of these codes are now gone, but the car still suffers from the same problem. I've seen a number of posts about similar problems with this car, and usually the answer everyone gets is the EGR-valve. That didn't help this car unfortunately. Would updating the software on the car be a soultion to this problem? Is there som sort of electronic throttle unit that can be replaced? Or is there some other mechanical issue that can be the root of the problem? I should mention that the yellow engine light comes and goes in periods depending on how long i drive. When i drive on the highway, and use the cruise control the car doesn't manifest this problem at all. But when driving in the city and suburbs at a slower speed, not using cruise control, the problem is present and continuous.
 

·
Registered
Joined
·
895 Posts
Couple things that come to mind would be to check and clean the throttle body and intake. Could possibly be a fuel delivery problem. If you rev the engine in neutral, is it responsive, or does it stumble and kind of fall on its face?
 

·
Registered
2016 CRV Touring AWD
Joined
·
3,774 Posts
Guessing you have a 2.2 diesel since you post in the diesel section. Age and miles please.
Any deferred maintenance?

Your post suggests poor fuel delivery as a possible cause. Have fuel pressure checked to ensure it's within specs. Have fuel filter replaced. If that's gummed up with dirt or collapsed, fuel delivery suffers. Replace air filter as well. You have to remove the air filter to get to the fuel filter so it's easy to do.
Get a bottle or two of diesel fuel injector cleaner. Car parts stores sell this in small bottles. If in England, Halfords sells them, Wynn's is one brand you will find there.

Also, if yours is an auto, when was the transmission fluid last replaced?
 

·
Registered
Joined
·
113 Posts
If it is fuel related try using Shell regular diesel,according to Honest John it contains more detergent than any
other brand,also supposed to give 50MPG to a 2.2cdti.So for a little bit extra it will prove if it can clean your fuel
supply out.Good Luck.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top