Honda CR-V Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I got a 07 crv exl with 110,000kms. It was really cold on Tuesday and my CEL light came on. I read the code and found it was P2A00 and P0133. A/F ratio sensor range/performance and O2 sensor circuit slow response. I cleared the codes thinking it might of been related to the cold weather. The light has not come back on even after 150+kms of driving. I check the cpu again just for curiosity and the P2A00 is there but no CEL light.

So my question is do I need to change my upstream (front) a/f oxygen sensor and if so what brand do you suggest. Denso, Bosch, Ac delco. I have noticed in the past couple of weeks my gas mileage is not as good as it used to be. I though it was my heavier winter tires.
 

·
Everything in Moderation
Joined
·
8,154 Posts
That is not a lot of KMs for an O2 sensor to go bad...but it could happen if you do a lot of stop & go or don't get the engine warmed up all the time. Poor MPG is the first indicator of O2 sensor problems. By nipping it in the bud you will prevent damage to the catalytic converter.


Definitely pay the extra bucks for the OE Denso oxygen sensor. Other brands do not perform well in the Honda engines...OE needs to be a "wide-band" sensor from others experience.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
thanks. I don't mind changing the sensor. I will look that the Denso first if not then the Bosch. It says its a wide band one on rock auto.
 

·
Everything in Moderation
Joined
·
8,154 Posts
If you buy from Rock Auto get the Denso.

It's the one with the little heart. :)
DENSO Part # 2349062
 
1 - 4 of 4 Posts
Top