Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter September's CR-V of the month Challenge HERE
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
On three occasions on one day I experienced sudden loss of power. There was a slight bang from the radio as it happened but no light indications on dashboard. Lost steering, engine & electrics. Re-starts straight away. The previous day it had made the same sound but I only lost the radio and sat nav and they re-set within minutes so I thought no more of it. It was towed to Honda garage and has been there a week. Download from the computer confirms loss but no fault codes are bought up. They have checked "all the normal things" but no faults have been found. They have driven it for about 100 miles at various speeds etc but can not get the fault to replicate. They have now said to take it away and if the fault re-occurs to note all driving conditions ie temp, speed, gear etc However I am very nervous of it as I do a lot of motorway driving where suddenly stopping in the fast lane might not be a good idea! Does anyone have any experience of exactly the same problem and what was the cure? Thanks for any help forthcoming.
 

·
Registered
Joined
·
41 Posts
I have not had this on my CR-V, but I had it on my BMW. Baffled the garage as there were no fault codes - turned out to be a intermittent fault with the main relay supplying electrical power to the engine.

Steve
 

·
Registered
Joined
·
24 Posts
Just wondered how you resolved the problem ,i know its an old thread but my 2.2 2007 has just stopped and wouldnt start,towed to taken to garage who told me its high pressure fuel pump -cost around £1600 quid , my car wouldnt start again though so I suppose its better in some ways then your situation.I was told there is a cog on the pump that shears off resulting in no fuel and expsensive repair !
 

·
Registered
Joined
·
1 Posts
Just wondered how you resolved the problem ,i know its an old thread but my 2.2 2007 has just stopped and wouldnt start,towed to taken to garage who told me its high pressure fuel pump -cost around £1600 quid , my car wouldnt start again though so I suppose its better in some ways then your situation.I was told there is a cog on the pump that shears off resulting in no fuel and expsensive repair !
hi i know this is an old post, but my 2008 crv 2.2 cdti has just developed the same symptoms, any help much appreciated
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top