Honda CR-V Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,182 Posts
Discussion Starter #1
Just installed the Curt C56370 light harness. I did not see in the written instructions, or the installation video, a ground wire installation. I presume a separate ground wire is not necessary (grounding is thru the factory connector). Test light shows running, brake and signal lights all functioning correctly.

I presume I'm good to go, yes?
 

·
Registered
Joined
·
499 Posts
Looks like it. Four wires coming out. Left stop/turn, Right stop/turn, tail and a ground. I would think if everything checks out you are good to go.
 

·
Registered
Joined
·
3,182 Posts
Discussion Starter #3
I just wasn't 100% positive about the ground. The Curt trailer light wire kit also includes one crimp-on eyelet and 2 crimp-on connectors. Again, nothing mentioned in the instructions about mounting a ground wire.....but wondering why Curt included the eyelet and crimps if not needed. Just a little :confused2:.
 

·
Registered
Joined
·
499 Posts
"Just a little :confused2:"

I stay that way 100% of the time!

I couldn't find any wiring schematics for either the Honda plug, or the Curt kit. Maybe you could call/email them and ask. I'd be interested in knowing.
 

·
Registered
Joined
·
3,182 Posts
Discussion Starter #5
I emailed both Curt and Etrailer and both responded back with the install instructions that came with the harness kit. Since the lights test ok, I'm calling it good. Now for a hitch.
 
1 - 5 of 5 Posts
Top