Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of December's Ride of the Month Challenge!
1 - 12 of 12 Posts

Registered
Joined
5 Posts
Discussion Starter · #1 ·
I have a 2011 4wd crv that I bought at a used car dealership last year that ive trusted for years. Yesterday the battery died while my wife was waiting on me at a doctor's appointment. I got a jump start from my dad and went to advance auto to check and get a new battery. ( turns out it had the stock battery from back in 2010 go figure). The vehicle just rolled over to 109k miles and after the jump and new battery all my dash lights keep blinking at random, my trip screen keeps going in and out, the drive indicator is flashing and so do half the other lights. I made sure it was connected properly and even disconnected it for about 15 minutes to see if it would reset but no luck. Where do I go from here?
 

Everything in Moderation
2006 CR-V EX, 5MT
Joined
12,199 Posts
Hopefully none of your car's electronics were damaged by the jump start.

Often, those indicators will go away after a few miles of driving.

If they don't, try disconnecting the NEGATIVE cable from the battery for 15 minutes. Before you reconnect it, touch it to the POSITIVE terminal (While you sing 'HAPPY BIRTHDAY TO ME', twice 馃榿 ). This, to totally reset any of the electronics' 'memories'.

Then take the car for a 10 minute drive...post back with results.
 

Registered
Joined
5 Posts
Discussion Starter · #3 ·
Hopefully none of your car's electronics were damaged by the jump start.

Often, those indicators will go away after a few miles of driving.

If they don't, try disconnecting the NEGATIVE cable from the battery for 15 minutes. Before you reconnect it, touch it to the POSITIVE terminal (While you sing 'HAPPY BIRTHDAY TO ME', twice 馃榿 ). This, to totally reset any of the electronics' 'memories'.

Then take the car for a 10 minute drive...post back with results.
No luck. I tried what you said then drove it to the end of the road . the lights continue to blink at random intervals lost my speedometer, parking brake light came on same with tire pressure sensor and antilock brake light. Check engine light stayed on but when I checked with my reader it's a powertrain/ emissions error
 

Registered
Joined
1,009 Posts
Error code new also after jump and battery?
Could also be an electrical issue

P0420 HONDA Possible Causes
What does this mean?
  • Faulty Three-way Catalyst Converter Bank 1
  • Exhaust Tube
  • Intake Air Leaks
  • Faulty Oxygen (O2) Sensor
  • Faulty Fuel injector(s)
  • Leaking Fuel Injector (s)
  • Faulty Spark plugs
  • Improper Ignition Timing
  • Faulty Engine Control Module (ECM)
  • Dirty Air Filter
 

Premium Member
Joined
2,694 Posts
Unless something has been damaged in the electrical system (even the ECU) the P0420 could be a completely separate problem.
 

Registered
Joined
2,517 Posts
Make sure all connections at the battery are tight.

The 420 code is a seperate issue, if electrical on the engine side was effected there would be far more codes.

Sounds like something was done incorrectly with the battery change/jump start. Either hooed up backwards or something left/knocked loose

Sent from my SM-N975U using Tapatalk
 
1 - 12 of 12 Posts
Top