Honda CR-V Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
2008 CRV LX 2WD, 52,000 miles.

About a week ago my power steering started to whine. I added a bit of fluid as it appeared to be low and went about my life. Problem solved. This past weekend it all started to come unglued. I now have a constantly audible whine and bubbling in the reservoir. I replaced the coupler o-ring as per the TSB and tried working air out of the system, but it had no effect whatsoever. The fluid is darker than I'm used to seeing though, almost like Coca-Cola.

There's no visible leak, no fluid on the garage floor, or really any indication of a problem. Other than the gawdawful noise and bubbling of course.

Prior to my owing it, the car was flat-towed behind an RV, but I've had it for more than 2 years with no issues until now. I take that back. About a year ago it burped up a lot of fluid and was whining for a few hours until I could get some fresh fluid into the system. It's been a peach ever since.

So. Take it to the shop, or is there something dumb and obvious I'm overlooking? Could flat-towing have damaged the system?

I have a video but the system won't let me embed it since I'm a new user. Sorry.
 

·
Registered
Joined
·
3,170 Posts
Foamy fluid means air the system. Try this lift both front tyres without the engine running turn it lock to lock 20 times. Then start the engine turn it lock to lock 20 times. I would suggest to drain the old fluid & replace it with Honda PS Fluid. Double check the return hose for damage & cracking. Let me know.
 
1 - 4 of 4 Posts
Top