Honda CR-V Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i replaced the radiator in my 2004 CRV EX 4wd. During install i had trouble with the connector at the bottom of the fan (above lower hose). First attempt to reconnect after install, i dd not get a click so pulled apart again and heard something fall. it was getting dark and could not find anything. i then pushed it together again and it easily clicked into place. after installing hoses and fans i found a square white plastic piece what appears to be the internal housing of one of the connectors in question. by this time it was tooo dark and i again could not disconnect the connector so i let it be.

what does this connector and wiring control? what symptoms would tell me that the connection is no good?

can i continue with installation, or should i take the time to remove fan and connection to reinsert that plastic housing or could it be left alone as is (seemingly connected but missing inner housing on one side)

thanks in advance
 

·
Everything in Moderation
Joined
·
8,200 Posts
Might be a locking tab....I would at least look for it.

Compare to the other fan connection....
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
the piece i found was indeed the inner part of the male end of the connector. i was able to disconnect, insert said piece and the 2 ends clicked back together easily so i think its good.

does anyone know what this wiring controls?

its different than the fan connectors at the top. located clipped to the bottom of fan, above the lower hose. in hindsight i probably did not need to pull it apart to remove radiator, just unclip from fan
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
if there is nothing clipped to bottom of anyone else's '02-04 CRV radiator fan its probably because the connector was ripped off the fan in frustration like i did. in that case it would be hanging, run horizontal, above the lower hose between the radiator and engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
all back together now and seems fine.
i had some worry because the AC fan wasnt turning on after changing radiator but found out all i needed was to add refrigerant and they kicked on. these CRVs run so cool i have yet to see the radiator fan come on by itself, but the engine temp never gets above normal.
 
1 - 5 of 5 Posts
Top