Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of December's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello folks.

I just had a hitch installed on my 2013 CR-V at a local Uhaul. Right as I drove out of the driveway I saw that the AWD light was on, solid. I drove back in. They had no idea what caused this.

Does anyone have a clue? I detached the battery and reconnected it, AWD light still on.

Thanks for any help you can provide. As is I have to call them back tomorrow for next steps and I'm planning to call the dealer also.

Burns
 

·
Registered
2012 CRV EX-L
Joined
·
140 Posts
Perhaps during the hitch installation they may have damaged or caused the sensor for the AWD system to cause the AWD light to come on. Maybe connect an OBD II scanner and see if a code for the sensor displays.
 

·
Registered
Joined
·
1,009 Posts
Came on as you were leaving? or you just noticed it then ? Check around the install area. Did they hook up wiring too? Was it a bolt-on or required welding?

Make/model of hitch ? Pictures.....
 

·
Registered
Joined
·
108 Posts
I installed the exact u-haul setup on my 2013 AWD 4 or 5 years ago and as far as the hitch and wiring goes there is nothing that comes near any AWD systems . It is pretty much plug and play. The only possible scenario I could imagine is when plugging the lighting harness in on the left side fender well under the plastic panel there is the AWD relay and the plugs for the lighting harness for the trailer connection are in the same area.
 

·
Registered
2020 CR-V hybrid Executive trim Premium Chrystal Red Metallic
Joined
·
82 Posts
Hitches and the CR-V's electronics are a tricky point. I had some trouble with my trailer's electrics and that was shown on the dash as a problem as I connected the trailer's electdrics to the car. The VSA and the cruise control stopped working every time I used the indicator stalk. About the VSA: the light came on. A simple reset at the dealer's solved the problem. Big chance that a reset will do the trick.
 

·
Registered
Joined
·
1,009 Posts
Hitches and the CR-V's electronics are a tricky point. I had some trouble with my trailer's electrics and that was shown on the dash as a problem as I connected the trailer's electdrics to the car. The VSA and the cruise control stopped working every time I used the indicator stalk. About the VSA: the light came on. A simple reset at the dealer's solved the problem. Big chance that a reset will do the trick.
Why does the dealer need to do the reset ? Can owner do that themselves ?
 

·
Registered
2020 CR-V hybrid Executive trim Premium Chrystal Red Metallic
Joined
·
82 Posts
I don't know. They hooked a laptop to the car and it was done within a few minutes. No charge.
 
1 - 10 of 10 Posts
Top