Honda CR-V Owners Club Forums banner
  • Submissions are now being taken for JUNE CR-V OF THE MONTH
  • Hello Everyone! Let us know what you would spend a $50 Amazon gift card on, HERE For a chance to win a $50 Amazon Gift Card!
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2017 CRV EX. I downloaded the Hondalink app to my Apple iPhone 6s Plus. I’ve connected my phone to the car via Bluetooth and that seems to work fine. After downloading the app to my phone, I entered my car information so my car is in the app. For about a month, the info about my car on the app dashboard (range, etc.) was current. Now when I bring up the app, I get the screen to connect to my car, even though the phone is already connected via Bluetooth. While i’m In the car, I get a message on the app that it is trying to connect to the car, but the app never shows it being connected. The result is that the dashboard information on the app, particularly the information about upcoming service, is not being updated on the app. Any suggestions for fixing this?

Thanks
 

·
Registered
Joined
·
2 Posts
Me too. I have a 2020 CR-V Touring. Phone connects fine via bluetooth, but HondaLink app on phone hangs. When I prese the HondaLink button on main display screen, the screen changes but nothing every shows up. Same result when pressing the Places button on navigation screen. I've unpaired and re-paired the phone (recent iPhone on current maintenance).
 

·
Registered
2020 Hybrid Touring
Joined
·
6 Posts
On Android, I haven't been able to set up HondaLink on Bluetooth since shortly after I bought the car. However, is I set my phone as a WIfi access point & connect the car by wifi, It works fine, which isn't saying a lot. HondaLink provides nothing I canIt get more easily with Android Auto
 

·
Registered
2020 Touring Hybrid
Joined
·
1,673 Posts
Me too. I have a 2020 CR-V Touring. Phone connects fine via bluetooth, but HondaLink app on phone hangs. When I prese the HondaLink button on main display screen, the screen changes but nothing every shows up. Same result when pressing the Places button on navigation screen. I've unpaired and re-paired the phone (recent iPhone on current maintenance).
The app on my iPhone connects and works, displays correct range, oil life etc, but when I select HondaLink on the main display screen in the car it is always just totally blank.

Have used with two different iPhones, same result.
 

·
Registered
Joined
·
4 Posts
I have a 2017 CRV EX. I downloaded the Hondalink app to my Apple iPhone 6s Plus. I’ve connected my phone to the car via Bluetooth and that seems to work fine. After downloading the app to my phone, I entered my car information so my car is in the app. For about a month, the info about my car on the app dashboard (range, etc.) was current. Now when I bring up the app, I get the screen to connect to my car, even though the phone is already connected via Bluetooth. While i’m In the car, I get a message on the app that it is trying to connect to the car, but the app never shows it being connected. The result is that the dashboard information on the app, particularly the information about upcoming service, is not being updated on the app. Any suggestions for fixing this?

Thanks
Me too! I have a 2020 exL and mine won’t link. Also my old car was a 2018 Honda Accord touring and that car would not pair either.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top