Honda CR-V Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello!

I recently had to jump my battery on my 2012 Honda CR-V and now the Multi-Information Display (MID) on the steering wheel (specifcially the Display button) isn't working to shuffle between the screens displayed on the dash.

Dealer of course wants to bring in for diagnosis and repair, but I suspect this is an easy fix I can do on my oqn.

Anyone else have this issue and have a solution to fix? Please let me know.

Thanks in advance for any tips! :)
 

·
Registered
Joined
·
295 Posts
An easy fix/try would be to disconnect the battery for a few minutes and reconnect. Don't forget to take note of the radio code before disconnecting.
Good luck and hopefully it will solve your problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Many thanks!

I disconnected the battery for a few minutes and reconnected and that solved the issue!

I can now scroll through the various screens on the MID.

Happy New Year! :cool:
 

·
Registered
Joined
·
8 Posts
Only place online I have found regarding this. I tried disconnecting the battery and reconnecting but that didn't solve the issue. Fantastic way to celebrate the vehicle being paid off this month. Any other suggestions besides the shop?
 

·
Registered
Joined
·
4 Posts
Plus check fuses!
Hi! Do you know which fuses control the i-MID controls on the steering wheel? I am having a problem with my steering wheel controls for the i-MID and the radio. It worked one time but have not since. I just tried the battery disconnect trick this morning and it still didn't work. I left it disconnected a good 10 mins. Not sure if I should have left it out longer. Thoughts?
 
1 - 7 of 7 Posts
Top