Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 13 of 13 Posts

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #1 ·
My infotainment system seems to mess up randomly. Many issues:

1. Sometimes when starting my car and hooking up my phone apple carplay will pull up as a black screen. Music will play, but no screen and tapping the screen does nothing. Going back to Home does display as normally but going into apple carplay will continue to be blank. Resetting the Head Unit and replugging in my phone fixes this most of the time.
2. Sometimes it refuses to connect and load apple car play at all. plugging in my phone it will charge so it is connected but the head unit will act as if NOTHING is connected to it at all. Resetting the head unit sometimes fixes this. Sometimes the whole car has to be turned off and restarted after a period to fix this.
3. The display in only apple car play will show "Yellowing" around the corners of the display. I can not tell if this is in other screens as other screens are black but I suspect it would show yellow in the corners. This seems to be worse when it is very hot in the car and less when it is not as hot. It does not affect anything it just looks bad.
4. Sometimes phone calls will not go through apple car play but will go through the home car screen. It will not allow me to go into apple car play until the call is over. Only turning off the car and coming back later will fix this issue. Carplay will work before and after this but just when I make a call it takes me out of carplay. Because I use a google voice number I call using google voice rather than the regular phone program most of the time.

All of this is driving me crazy, any help with these?
I Have an Iphone 11 with the latest ios and it works fine. I do have Honda Hack installed in the head unit and use some minor settings from that program.

2020 CRV Hybrid Ex-L.
 

·
Registered
2020 Touring Hybrid
Joined
·
718 Posts
My infotainment system seems to mess up randomly. Many issues:

1. Sometimes when starting my car and hooking up my phone apple carplay will pull up as a black screen. Music will play, but no screen and tapping the screen does nothing. Going back to Home does display as normally but going into apple carplay will continue to be blank. Resetting the Head Unit and replugging in my phone fixes this most of the time.
2. Sometimes it refuses to connect and load apple car play at all. plugging in my phone it will charge so it is connected but the head unit will act as if NOTHING is connected to it at all. Resetting the head unit sometimes fixes this. Sometimes the whole car has to be turned off and restarted after a period to fix this.
3. The display in only apple car play will show "Yellowing" around the corners of the display. I can not tell if this is in other screens as other screens are black but I suspect it would show yellow in the corners. This seems to be worse when it is very hot in the car and less when it is not as hot. It does not affect anything it just looks bad.
4. Sometimes phone calls will not go through apple car play but will go through the home car screen. It will not allow me to go into apple car play until the call is over. Only turning off the car and coming back later will fix this issue. Carplay will work before and after this but just when I make a call it takes me out of carplay. Because I use a google voice number I call using google voice rather than the regular phone program most of the time.

All of this is driving me crazy, any help with these?
I Have an Iphone 11 with the latest ios and it works fine. I do have Honda Hack installed in the head unit and use some minor settings from that program.

2020 CRV Hybrid Ex-L.
I think someone has pointed out Honda Hack and CarPlay don’t play well together. @beww will know for sure.
 

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #3 ·
I think someone has pointed out Honda Hack and CarPlay don’t play well together. @beww will know for sure.
I want to try uninstalling it and seeing if that fixes some issues but that could be the problem. It sucks tho because I really like Honda hack and a couple of the features it brings to the system.
 

·
Registered
2020 Touring Hybrid
Joined
·
718 Posts
I want to try uninstalling it and seeing if that fixes some issues but that could be the problem. It sucks tho because I really like Honda hack and a couple of the features it brings to the system.
Might be worth a try. I’ve got a 2020 Hybrid Touring and use an iPhone 10 with latest iOS and it works pretty flawlessly. In 13 months I’ve had probably 2 occasions where it didn’t launch CarPlay when I plugged in the phone, but next start cycle of the car would resolve. I assume you are using an OEM lightening cable or at least MFI certified?
 

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #5 ·
I assume you are using an OEM lightening cable or at least MFI certified?
MFI certified yes. It is a high quality cable. Yea I will try it. I just hate the popup it displays every single time you start the car. Oh well. I can always reinstall honda hack at any time. Honestly if these problems are being caused by Honda hack then the issues with it are becoming worse than not having it.
 

·
Super Moderator
2007 Accord EX 2020 CR-V Hybrid EX
Joined
·
3,254 Posts
I think someone has pointed out Honda Hack and CarPlay don’t play well together. @beww will know for sure.
Actually I don't know for sure, I don't have or use an iPhone.
I have HH installed and I get none of the issues the OP mentioned, but of course I don't use Carplay, or AA.
What I do is run whatever nav or entertainment apps I want directly on the head unit itself, not on a phone. Usually SiruisXM and Waze.
You need a hotspot for the HU to connect to, a phone will work.

The suggestions at the end of this might be of help:
 
  • Like
Reactions: EXcommunicated

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #7 ·
Actually I don't know for sure, I don't have or use an iPhone.
I have HH installed and I get none of the issues the OP mentioned, but of course I don't use Carplay, or AA.
What I do is run whatever nav or entertainment apps I want directly on the head unit itself, not on a phone. Usually SiruisXM and Waze.
You need a hotspot for the HU to connect to, a phone will work.

The suggestions at the end of this might be of help:
Yea sounds like I need to get rid of it if I am going to get rid of these issues. Thanks for the tips.
 

·
Super Moderator
2007 Accord EX 2020 CR-V Hybrid EX
Joined
·
3,254 Posts
Not sure if you mean get rid of the Head Unit or the car. :)
Options for replacing the Head Unit are extremely limited, at least according to Crutchfield.
 
  • Like
Reactions: De$perad0

·
Super Moderator
2017 CRV Touring - Pearl White w Black Interior
Joined
·
6,638 Posts
Definitely remove HondaHack (you can always reinstall it later) and restore the headunit to OEM stock. Then go back and test things out. Because with your new CRV, if you end up needing the dealer to troubleshoot.... that is the first thing they will do is blow away HondaHack... assuming they will even agree to warranty work on your head unit that has had HondaHack applied to it.

I guess it would not surprise me that a 5 year old head unit design, with an old Android OS (stable, just old), may not play well with CarPlay/iPhone in conjunction with HondaHack. We do have members that use HondaHack, but I do not recalll if any of them have reported issues with CarPlay and your particular iPhone.

One of the difficulties in members comparing notes where phone paring and head unit are concerned is there are so many variations of phones in users hands and some work without issue, and others seem to have more than their fair share of issues.
 
  • Like
Reactions: De$perad0 and beww

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #10 ·
Not sure if you mean get rid of the Head Unit or the car. :)
Options for replacing the Head Unit are extremely limited, at least according to Crutchfield.
Lol I meant get rid of Honda Hack on the head unit!

Definitely remove HondaHack (you can always reinstall it later) and restore the headunit to OEM stock. Then go back and test things out. Because with your new CRV, if you end up needing the dealer to troubleshoot.... that is the first thing they will do is blow away HondaHack... assuming they will even agree to warranty work on your head unit that has had HondaHack applied to it.

I guess it would not surprise me that a 5 year old head unit design, with an old Android OS (stable, just old), may not play well with CarPlay/iPhone in conjunction with HondaHack. We do have members that use HondaHack, but I do not recalll if any of them have reported issues with CarPlay and your particular iPhone.

One of the difficulties in members comparing notes where phone paring and head unit are concerned is there are so many variations of phones in users hands and some work without issue, and others seem to have more than their fair share of issues.
Yea that seems to be the course of action to take here. There are so many different phones out there. I just got the unlucky one it seems. However I need to make sure it is truly a Honda Hack issue and not a Head Unit issue that needs dealer work done.
 

·
Super Moderator
2007 Accord EX 2020 CR-V Hybrid EX
Joined
·
3,254 Posts
Yea that seems to be the course of action to take here. There are so many different phones out there. I just got the unlucky one it seems. However I need to make sure it is truly a Honda Hack issue and not a Head Unit issue that needs dealer work done.
Easy enough to determine, just remove HH.
Have you checked with the HH support? I don't follow them but they should be able to tell you if it's a known issue.
 

·
Registered
2020 CR-V EX-L Hybrid
Joined
·
78 Posts
Discussion Starter · #12 ·
Easy enough to determine, just remove HH.
Have you checked with the HH support? I don't follow them but they should be able to tell you if it's a known issue.
I have not checked with them. To be honest I didn't think they had a support system at all!
 

·
Super Moderator
2007 Accord EX 2020 CR-V Hybrid EX
Joined
·
3,254 Posts
I have not checked with them. To be honest I didn't think they had a support system at all!
From their site:
"If you have any question, please feel free to contact me at: [email protected]. You can also post your question to the Honda Hack thread at xda-developers.com to get help from other people."
 
  • Like
Reactions: JB in AZ
1 - 13 of 13 Posts
Top