Honda CR-V Owners Club Forums banner
  • Hey everyone! Enter your ride HERE to be a part of December's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Howdy,

both of my turning signals work fine in the daytime, however when i turn my lights on the left indicator stays solid on. There is no flashing and when I turn my indicator left there is no change. My right signal works fine.

Any help is appreciated!! I drive a 2001 if that helps


Dan
 

·
Everything in Moderation
2006 CR-V EX, 5MT
Joined
·
12,154 Posts
You could have a bad bulb (shorted filaments) or even a bulb that isn't twisted fully into place.

Also, check ground wires to that LH bulb socket...no ground forces the 'lectricity to find its own path back to the battery...through a different filament.

Post back with results.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I changed all 4 bulbs, on the left and the right side. The problem now is that the brake light on the right side flashes when i turn my left blinker on! Also, when I use my right blinker now, the right brake light fails to flash.

I have ruled out bulbs, and will look into the grounds. Is there a useful vid that helps out with the grounds? im not the best with cars but im working with a dude who's pretty adept.
 

·
Registered
'07 CR-V EX-L AWD
Joined
·
4,662 Posts
Are you the original owner? If not, you may want to look for evidence of "custom" wiring done by a previous owner. It sounds like something has been changed. Does your V have a trailer hitch? If so, your issue might be found in the trailer light wiring harness connections. Otherwise, it could still be a bulb out, just not one you've changed yet. Could also be corrosion in a socket, and if not cleaned up, a new bulb won't help.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Larry,

Not the original owner and im sure the guy before me had some weird electrical stuff going on. My parking brake light is on all the time actually haha but i didnt seem to think it was that big of a deal.

I will take your advice and check out the wiring connections of the trailer light. there is evidence of a hitch used in the past but it no longer has a hitch
 

·
Registered
'07 CR-V EX-L AWD
Joined
·
4,662 Posts
On your parking brake light issue, you could check the switch. Sometimes the bracket can come loose, or the switch can come loose and/or get out of adjustment, or the switch could have just gone bad and need replacing.
 

·
Registered
Joined
·
1,644 Posts
When they get old the floats don't float properly in the master cylinder cap. I have found that if I keep my brake fluid all the way to the max mark the light stays off. If it starts running a little lower and gets cold outside the light comes on.
 
1 - 8 of 8 Posts
Top