Honda CR-V Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi everyone, this is my first post!! I've read the last post about cleaning lens and disassembly of nav sat; i have the same navsat posted, and i don't know why it won't turn on!!!!:mad:it's like dead..... So i have plugged wires directly to plug, shown in the picture......i have two questions:
1) Is pinout of plug shown right? +12V, GND and +12V on the ignition key pin and nav sat should turn on, right?
2) Is inside navsat any fuse?:confused:

Anyone had my same problem with this navsat??:confused:
THANK you so much....!!!:)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Yes, this is BB714PH....

....pinout showed is the correct one. Anyway i'm keep on tryin to make it turn on...
Thank you.....
 

·
Registered
Joined
·
1 Posts
Did you ever sort this out ? I have this satnav in my "55" CRV and since the alternator died & was replaced the satnav/CD/radio is dead, will not power on. Have checked fuses under dashboard & in engine bay - although the fuse layout is rather vague...cannot find any reference to any fuse in the unit itself.
 

·
Registered
Joined
·
2,554 Posts
Are these units protected by a code of some sort to prevent theft?
 

·
Registered
Joined
·
4 Posts
Inquiring if this issue has been resolved and how? This is my first post, so I hope someone can help.

I have a 2007 Honda CRV, EX-L with Navigation.
My issue is that my navigation screen/radio will not turn on after having CRV towed, alternator & battery replaced by Automotive shop. I had checked & replaced fuse #34 just to eliminate any doubts and still can't get unit to power on.

Suggestions?
 

·
Registered
Joined
·
4 Posts
Inquiring if this issue has been resolved and how? This is my first post, so I hope someone can help.

I have a 2007 Honda CRV, EX-L with Navigation.
My issue is that my navigation screen/radio will not turn on after having CRV towed, alternator & battery replaced by Automotive shop. I had checked & replaced fuse #34 just to eliminate any doubts and still can't get unit to power on.

Suggestions?
I have exact same problem, did anyone get this resolved
 
1 - 7 of 7 Posts
Top