Honda CR-V Owners Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 03 CRV- Auto that I got about 5 months ago, it has high mileage (190,000). About 3 months ago the check engine light came on and immediately the car begins bogging and jerking upon acceleration. It feels like it goes into a limp mode. It can barely be driven it will slow down to nothing going up a hill as soon as you touch the gas pedal it will start jerking . Once I let go of the gas it immediately stops.

We took it to an auto place to read the check engine light and we got the P1259 which recommends replacing Vtech pressure switch so I replaced the entire solenoid unit. Car went back to running great again, a month later the same problem happened. I thought maybe it was a faulty part so I returned the original and got a replacement. Again, drove great for another month. Now the same problem is back. Could it be a coincidence of a bad part or could something be causing it to keep failing? Thanks for any help!!!
 

·
Registered
Joined
·
1 Posts
Did you ever get this fixed? Bummer no one replied to try and help you. Of course, I have a P1259 code on mine. Going to replace the oil pressure switch first, along with the little screen (hoping no metal debris found there!).
 

·
Everything in Moderation
Joined
·
8,191 Posts
This sounds like yet another incidence of poor replacement part quality.

Best Practice is to buy genuine Honda, but of course the cost will be higher.


Perhaps, using a brand of part with a HEART next to it (on the RockAuto.com listings) or a brand that 'says XXX was the original manufacturer' is a good strategy.
 
1 - 3 of 3 Posts
Top