Honda CR-V Owners Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2007 honda crv 2.2 diesel (ctdi) and only had it a short while. I've noticed the turbo chatters really loudly, it whistles but not too much. Its the chattering of the wastegate / turbo that worries me. On top of this I have noticed there is a fair bit of turbo lag, it only spalls at around 2500 rpm and if you change gear early it drops off and becomes very sluggish until the revs build up again. Also the mpg is terrible, 28 mpg average on short journeys and a maximum of 35 mpg on motorways. Not sure if its all related? Sometimes I will notice a slight hesitation at around 1500 rpm with very little throttle.

Summary:
- Poor fuel consumption 28-35 MPG
- Very Slight hesitation at 1500 rpm
- Turbo lag and not spooling until 2500 rpm
- Noisey wastegate / turbo chatter

What I've done so far:
- Noticed the secondary cat has been removed and straight pipe welded in
- Replaced all the vacuum lines and sensors on top of the engine
- Removed EGR and cleaned it all out (loads of thick black sludge)
- Put DPF / Turbo cleaner in the tank and given it an italian road test
- Replaced the fuel filter with OE quality filter (Mann)
- Fully serviced changing all filters and oil

Anyone else had similar faults and come up with a solution or can point me in the direction of trial and error? I was thinking of removing the pre cat and remapping it but not sure the company I use can do a custom map to tell the ecu the pre cat is missing.
 

·
Registered
Joined
·
4 Posts
Did you have any success diagnosing?
Your description sounds exactly like my CRV same year. Had the waste gate chatter for quite some time, and its hit over boost limp mode a couple of times, so currently doing the fuel turbo clean additive at the moment
 

·
Registered
Joined
·
73 Posts
Hi Guys,
Not sure if this will be your issue because you say you checked all the vacuum stuff on top of the engine. However, I had an odd hestiation at low revs and turbo noise...sounded like a dry bearing to me but I hoped that it wasn't and had no idea what sort of noises a turbo should/could make.
Anyway, after two trips to the dealership where they put the car on the diagnostics and reported faulty injectors both times! I finally found the issue myself...accidentally.

There are two Solenoid controlled valves at the top of the engine. One operates the variable vanes on the Turbo and is situated at the rear of the engine and the other operates the EGR valve and is siutated at the front. They are identical valves and so I set out to swap them around one day as an experiment.
On attempting to remove the EGR one the vacuum stem pulled right off with the pipe! There had been a cracked stem which changed as it heated up and allowed a vacuum leak and therefore affected the operation of the ER valve OR simply allowed a Vacuum leak to the engine which affected the performance? Not sure which it was but, for me, replacing the front Vacuum solenoid valve cured my problem.
Not cheap given the two visits to Honda for false reporting of the faulty injectors plus the cost of a Honda Solenoid valve!!

I had the INjectors pulled and tested not long after and they were fine!

As I say, might not be your problem but...every little helps as they say :)

Good luck.

James
 
1 - 3 of 3 Posts
Top