Honda CR-V Owners Club Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited by Moderator)
Radiator fan keeps running after I turn ignition off

Hello All,
I just bought my CRV today. There was a funny sound after I turned the ignition off. I figured out that it was the radiator fan running.

After searching online I figured out that it may be normal when the engine runs for 30 minutes or so but what is really concerning me is that when I drove it for just 1 mile in my neighborhood, it still was on for 5-10 minutes afterwards.

All my excitement has evaporated. Is it normal or is there a problem? (The temperature today is 95F)

Please help

Hello All,

I just bought my CRV today. There was a funny sound after I turned the ignition off. I figured out that it was the radiator fan running.

After searching online I figured out that it may be normal when the engine runs for 30 minutes or so but what is really concerning me is that when I drove it for just 1 mile in my neighborhood, it still was on for 5-10 minutes afterwards.

All my excitement has evaporated. Is it normal or is there a problem? (The temperature today is 95F)

Please help

I just bought my CRV today. There was a hissing sound after I turned the ignition off. I don't know what that sound is from

I drove it for just 1 mile in my neighborhood and there still was a nhissing sound for about 5-10 minutes after I turned the ignition off

All my excitement has evaporated. Is this normal or is there a problem? (The temperature today is 95F)

Please help

Thank you very much
 

·
Registered
Joined
·
1,592 Posts
All is well. Go forth and stay excited about your new CR-V.

In warmer weather the fans operate more. It is normal for them to run for a while after shut off.

Cheers, JimBob
 
1 - 2 of 2 Posts
Top