Honda CR-V Owners Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I had a bad SRS unit about 1.5 years ago (7-2 error code), which I paid to have replaced at the dealership. Since then, I've been getting a 15-2 (OPDS sensor) error code. Fortunately that was under warranty, so the dealership replaced the entire OPDS system twice, I paid to have the passenger seat harness replaced, and then complained enough that they did their last resort repair for free: replacing the main harness (each of those were separate repairs occurring over the past year and a half). The SRS light and the 15-2 code still comes on! No one can reproduce it predictably, but it usually comes on within days, although there have been times where it was off for a string of a few months.

Based on my prior mechanical experience, I always found it doubtful that the main harness coincidentally went bad after the SRS unit was replaced, and rather it might be a bad SRS unit or that there may be a calibration that has to be done with the OPDS system or SRS unit. Unfortunately I don't have the factory service manual so I can't verify this for myself! Of course I will be taking it back to the dealership to complain more, but I'd really like to know if there is any possibility that it is a faulty unit or uncalibrated system or something else.

Any advice please? Thank you!

BTW, I'd love the have the Honda factory service manual anyway; any recommendations on how to get one?

EDIT: 2004 CR-V EX. ~130k miles. Single owner (me). No major repairs done other than like a dented door. Everything always done at dealership. My automotive experience pertains to '80s Japanese cars, not my CR-V.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sorry! I thought that information would show up next to my name!. 2004 CR-V EX. More details in my edited original post! Thanks!
 
1 - 3 of 3 Posts
Top