Honda CR-V Owners Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi all. I have a 2010 Honda CRV and this came loose under the car earlier today after going through some water. After the water, it was only secured in two places and was dragging along under the car so I had to remove it on the road as I didn't want it damaging anything else if it was to break away. You can't see in this picture but there's some other holes were it was once secured to the car but had since fatigued away and now worn off so I guess it was a matter of time until it came off.

In the pictures below, you can see where it was hanging off (under the gearbox) and the piece once removed (better picture to follow tomorrow if required).

If someone can point me in the right direction to getting a replacemment I'd appreciate it it.

P.S. Since found out this might be an engine splash cover (based on this: Engine splash cover screws). Any idea where I can get a replacement if that's the case?

Thanks

137607
137609
 

·
Registered
Joined
·
7 Posts
Hi all. I have a 2010 Honda CRV and this came loose under the car earlier today after going through some water. After the water, it was only secured in two places and was dragging along under the car so I had to remove it on the road as I didn't want it damaging anything else if it was to break away. You can't see in this picture but there's some other holes were it was once secured to the car but had since fatigued away and now worn off so I guess it was a matter of time until it came off.

In the pictures below, you can see where it was hanging off (under the gearbox) and the piece once removed (better picture to follow tomorrow if required).

If someone can point me in the right direction to getting a replacemment I'd appreciate it it.

P.S. Since found out this might be an engine splash cover (based on this: Engine splash cover screws). Any idea where I can get a replacement if that's the case?

Thanks

View attachment 137607 View attachment 137609
I had the same problem -- somehow the front part came loose and got folded back. I have not yet removed it, but I think the folks at the dealership are not tightening these down adequately.
 
1 - 3 of 3 Posts
Top