Honda CR-V Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I own Honda CR-V 2010 diesel 65 k miles. My turbo died so I had it replaced with reconditioned unit.
Mechanic told me that the reason was that air intake hose was split and car was taking too much air and fuel as a result. New turbo makes whining noise under boost between 1000 and 1500 rpm. I wonder if this is the issue with the new turbo or some underlying problems.
 

·
Moderator
Joined
·
2,804 Posts
Welcome to the forum! Moved to Diesel.
 

·
Registered
Joined
·
147 Posts
Check all your turbo hoses, pipework and intercooler first, then you need to the turbocharger boost pressure reading. Do you have any smoke emissions’ from the exhaust and what colour if any.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Hi, no unusual smoke coming out of the exhaust. I will check turbo hoses and intercooler.
Thank you for help.
 

·
Registered
Joined
·
89 Posts
Hi,

I own Honda CR-V 2010 diesel 65 k miles. My turbo died so I had it replaced with reconditioned unit.
Mechanic told me that the reason was that air intake hose was split and car was taking too much air and fuel as a result. New turbo makes whining noise under boost between 1000 and 1500 rpm. I wonder if this is the issue with the new turbo or some underlying problems.
Go to you tube,put in how to replace turbo,it sounds like oil supply to turbo,if so those who changed it should have checked
this before swopping the turbo.
 
1 - 6 of 6 Posts
Top